Gadget - Elevated error rates for API writes – Incident details

All systems operational

Elevated error rates for API writes

Resolved
Partial outage 5 %
Started about 11 hours agoLasted about 1 hour

Affected

API writes

Partial outage from 9:05 PM to 10:23 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Identified
    Identified

    API writes are occasionally failing with a Gadget framework issue like:


    Cannot read properties of null (reading 'SinceLastPersisted')



    We're reverting the offending change and will update when it has rolled out.