Gadget - Initial yarn installs on new apps failing due to broken rollup dependency upstream – Incident details

All systems operational

Initial yarn installs on new apps failing due to broken rollup dependency upstream

Resolved
Degraded performance
Started 3 days agoLasted about 6 hours

Affected

Code editing

Degraded performance from 4:00 PM to 10:12 PM

Updates
  • Resolved
    Resolved

    rollup has released a fixed version, so this incident has been resolved.

  • Identified
    Identified

    rollup on NPM has released a broken version that can't be installed, so new Gadget applications are breaking trying to install it.

    You can fix this on your newly created applications by adding a resolution to a previous working version of rollup:

    ```
    "resolutions": {
    "vite": "github:gadget-inc/vite#vite-v6.3.5-gitpkg-1f0e9a3d8",
    "rollup": "4.52.5"
    },

    ```