Gadget - Elevated 429 errors for Shopify OAuth Installation from Shopify – Incident details

All systems operational

Elevated 429 errors for Shopify OAuth Installation from Shopify

Resolved
Degraded performance
Started 11 days agoLasted about 19 hours

Affected

Shopify Plugin

Degraded performance from 4:00 AM to 6:49 PM, Operational from 6:49 PM to 10:47 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    Shopify has deployed a fix and OAuth install 429 errors have subsided. We'll continue to monitor and update if the situation changes. We've also developed a workaround we will deploy if this issue arises in the future.

  • Update
    Update

    Shopify has confirmed an issue on their end and is in the process of rolling out a fix.

  • Identified
    Identified

    Shopify has been erroneously returning an elevated number of 429 Too Many Requests status codes for the "/admin/oauth/access_token" used during app install. These requests are necessary for completing an install, so Shopify merchants are occasionally unable to complete the install of new Shopify applications. Gadget's telemetry indicates there is not actually a high number of requests being sent, so we believe this is a bug on Shopify's end and have reported it to them and are awaiting their feedback.

    The error is intermittent and comes in bursts, and retries of installs often succeed when attempted ~5 minutes later.

    We will update this incident as we learn more.