Gadget - High error rates making read or write requests – Incident details

All systems operational

High error rates making read or write requests

Resolved
Partial outage
Started 25 days agoLasted 21 minutes

Affected

API writes

Major outage from 8:56 PM to 9:00 PM, Operational from 9:00 PM to 9:17 PM

API reads

Major outage from 8:56 PM to 9:00 PM, Operational from 9:00 PM to 9:17 PM

Shopify Plugin

Major outage from 8:56 PM to 9:00 PM, Operational from 9:00 PM to 9:17 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. This incident was caused by test improvements to Gadget's load balancing strategy made to a test environment impacting the production environment unexpectedly. We've reverted the offending change, and will prioritize work to fully isolate this test environment where it cannot impact production at all. We apologize for any inconvenience this downtime has caused!

  • Monitoring
    Monitoring
    Automation: This incident has been resolved.
  • Investigating
    Investigating
    We are currently investigating this incident.