Gadget - Increased latency and timeouts with some DB queries – Incident details

All systems operational

Increased latency and timeouts with some DB queries

Resolved
Degraded performance
Started 8 days agoLasted about 9 hours

Affected

API writes

Degraded performance from 3:30 PM to 5:14 PM, Operational from 4:05 PM to 5:14 PM, Degraded performance from 5:14 PM to 12:55 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We implemented a fix and are currently monitoring the result. We are seeing DB writes returning to normal and a reduction in the number of transaction timeouts.

  • Identified
    Identified

    We believe we have found the issue and are working on mitigating it.

  • Update
    Update
    We are currently investigating this incident.
  • Investigating
    Investigating
    We are currently investigating this incident.